webpack-dev-server –inline –progress –config build/webpack.dev.conf.js

vue 项目 npm run dev 运行时报错: npm ERR! xxx@1.0.0 dev: `webpack-dev-server –inline –progress –config build/webpack.dev.conf.js`

 

原因:新版的webpack-dev-server 3.1.14 存在问题。

解决方法:package.json 中指定 webpack-dev-server 低版本号

方法1:

“webpack-dev-server”: “^2.9.1”

删除 node_modules 目录,再重新安装依赖包

npm install -S      // 这种方式安装的时间会长些,也可以只重装 webpack-dev-server模块

 

方法2:单独重装 webpack-dev-server模块

(1)、npm uninstall webpack-dev-server

(2)、npm install webpack-dev-server@2.9.1

(3)、npm run dev

 

转载于:https://www.cnblogs.com/linkenpark/p/10386937.html