Android Gradle项目依赖

打印构建项目所有的依赖

gradlew app:dependencies
或
gradlew :app:dependencies --configuration releaseRuntimeClasspath

在这里插入图片描述
打印的依赖格式说明:

x.x.x(*) 表示该依赖已经有了,将不再重复依赖
x.x.x -> x.x.x 表示该依赖的版本被箭头所指的版本代替
x.x.x -> x.x.x(*) 表示该依赖的版本被箭头所指的版本代替,并且该依赖已经有了,不再重复依赖

在这里插入图片描述

=========================================================
依赖冲突的本质:
有多个lib引入同样的依赖
在这里插入图片描述

不同的surpport库中依赖同一个lib的库的版本可以相同,这样会造成依赖冲突
在这里插入图片描述

========================================================
使用exclude去除依赖
在这里插入图片描述
在这里插入图片描述

其他用法:
在这里插入图片描述

延申:
去除项目中所有对annotaion的依赖

//app/build.gradle中添加下面代码
configurations {
    configuration{
        all*.exclude module: "annotation" //去除项目中所有annotation的依赖
    }
}

在这里插入图片描述

=========================================================
强制指定某个依赖库的版本
在这里插入图片描述
或者
在这里插入图片描述


版权声明:本文为Redmoon955331原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。