PAT1078. Hashing (25)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -
解这道题要知道二次探测法的公式: hi=(h(key)+i*i)%m 0≤i≤m-1 //即di=i2
   即探查序列为d=h(key),d+12,d+22,…,等。
当场考试有十几个人拿了满分,他们都懂这个么。。。。是他们太牛还是我太弱了=。=
代码:
#include <iostream>
#include <string.h>
using namespace std;
bool isPrime(int x){
	if (x == 1) return false;
	if (x == 2 || x == 3) return true;
	for (int i = 2; i*i <= x; i++){
		if (x%i == 0)
			return false;
	}
	return true;
}
bool mark[10000];
int main(){
	int m, n, x, i;
	cin >> m >> n;
	memset(mark, false, sizeof(mark));
	while (isPrime(m) == false) m++;
	while (n--){
		cin >> x;
		for (i = 0; i < m; i++){
			if (mark[(x + i*i)%m] == false){
				cout << (x + i*i) % m << (n ? " " : "\n");
				mark[(x + i*i) % m] = true;
				break;
			}
		}
		if (i == m)
			cout << "-" << (n ? " " : "\n");
	}
	return 0;
}



版权声明:本文为xtzmm1215原创文章,遵循CC 4.0 BY-SA版权协议,转载请附上原文出处链接和本声明。