Maven依赖编译失败报错:Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile

推荐 源码巴士 727浏览

报错笔记:IDEA2021无法执行compile编译Maven依赖

当我们对一个从github或其他人手里等其来源得到的Maven项目,进行执行compile编译pom.xml文件依赖时,经常出现Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile (default-compile) on project XXX: Fatal error compiling 的报错信息。

这种情况下,错误一般来源于项目所使用的JDK版本和Maven所使用的JDK版本不同所致,最好的解决方案是将项目和Maven所使用的JDK版本都设置为原项目所使用的JDK版本。
更换项目JDK版本方法:File-Project Structure-Project Settings-Project,点击选择自己下载到本地的JDK即可,如图:在这里插入图片描述
更换Maven的JDK版本方法:File-Settings-Build-Build Tools-Maven-Runner,点击选择自己要用的JDK即可,如图:
在这里插入图片描述
若pom.xml文件中包含了java版本,则maven优先使用pom.xml文件中的java版本,此时按照上述方法修改无效,需将pom.xml文件中的<java.version>改为和项目相同,如图:
在这里插入图片描述

这里贴一个可以下载各个版本的JDK的网站:http://openjdk.java.net/projects/jdk8/

转载请注明:源码巴士 » Maven依赖编译失败报错:Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile